Samba远程代码执行漏洞(CVE-2017-7494)分析

作者: cyg07 && redrain

概述

2017年5月24日Samba发布了4.6.4版本,中间修复了一个严重的远程代码执行漏洞,漏洞编号CVE-2017-7494,漏洞影响了Samba 3.5.0 和包括4.6.4/4.5.10/4.4.14中间的版本。360网络安全中心 和 360信息安全部的Gear Team第一时间对该漏洞进行了分析,确认属于严重漏洞,可以造成远程代码执行。

技术分析

如官方所描述,该漏洞只需要通过一个可写入的Samba用户权限就可以提权到samba所在服务器的root权限(samba默认是root用户执行的)。

从Patch来看的话,is_known_pipename函数的pipename中存在路径符号会有问题:

1.png

再延伸下smb_probe_module函数中就会形成公告里说的加载攻击者上传的dll来任意执行代码了:

2.png

具体攻击过程:

  1. 构造一个有’/’ 符号的管道名或路径名,如 “/home/toor/cyg07.so”

  2. 通过smb的协议主动让服务器smb返回该FID

  3. 后续直接请求这个FID就进入上面所说的恶意流程

具体攻击结果如下:

1.尝试加载 “/home/toor/cyg07.so” 恶意so

3.png

2.其中so 代码如下(加载时会调用 samba_init_module 导出函数)

4.png

3.最后我们可以在/tmp/360sec中看到实际的执行权限(带root权限)

5.png

解决方案

360网络安全响应中心和360信息安全部建议使用受影响版本的用户立即通过以下方式来进行安全更新操作,

  1. 使用源码安装的Samba用户,请尽快下载最新的Samba版本手动更新;

  2. 使用二进制分发包(RPM等方式)的用户立即进行yum,apt-get update等安全更新操作;

缓解策略:用户可以通过在smb.conf的[global]节点下增加 nt pipe support = no 选项,然后重新启动samba服务, 以此达到缓解该漏洞的效果。

原文:http://blogs.360.cn/blog/samba%e8%bf%9c%e7%a8%8b%e4%bb%a3%e7%a0%81%e6%89%a7%e8%a1%8c%e6%bc%8f%e6%b4%9ecve-2017-7494%e5%88%86%e6%9e%90/


发表评论

(必填)

(必填)

(以便回访)